B&P hacked Again… And fixed (I think)

HackedI’ve learned that Bits & Pieces has been hacked with a Google redirect hack.  If you typed bitsandpieces (or anything else that displays a link to B&P) into Google search and click the link you will be re-directed to another site.  (A site that doesn’t come up).  It also affects Google Reader I understand. 

I have found some rogue code in the .htaccess file that did the redirect.  I replaced it with the correct code and it seems OK now.  Now I have to wait and see if some malware reinstalls the hack code.  I’ll also do a complete computer scan overnight tonight.

 Stay tuned.

18 thoughts on “B&P hacked Again… And fixed (I think)”

  1. Thought something was off…retyped 3 times & got odd result. Was able to access thru one of your blogroll sites with no problem. Realized may have been a virus, so did a malware scan. Can’t be without my bitsandpieces!

      • Jonco – I have all three of your sites bookmarked; the only issue I had was that I could not save a comment on Bits of Wisdom–this was yesterday. The message I got said I should go back and enter a password.

        • Jonco – I tried adding a comment on Bits of Wisdom and got this WordPress error: “Error 1: click back and type in the password”

          • Tim,
            I fixed the problem. It was a new plugin I was trying. Didn’t realize it would do that so I deactivated it and made a test comment. Seems to work now.

  2. guess I was out during the problem. All looks well now. This seems to be a big issue with your site Jonco – wish we could help!

  3. HAHAHAHA Jonco! Hubby’s a computer whiz…don’t bookmark bc who knows what OS I end up with! But I’m ALWAYS here daily!!!!(And then some). Bullwinkle says ‘hello’!
    And Boris n’ Natasha wished they could’ve made the BBQ…
    Boris Badenov: Ah, it good to be back on campus.
    Natasha Fatale: Boris, you went to college? Penn State?
    Boris Badenov: No, state pen.

    • LOL
      Bookmark it on all your browsers and/or OS’s.

      Thanks for being part of the B&P Neighborhood. 🙂

    • I’m with GoDaddy for this site. Dreamhost for another site. Have really had no problems there yet (Knocks on wood)

  4. Your website has nothing to do with your local computer. Change your FTP password, make sure it’s a strong one (include capital letter, lower case letter, character such as ! or ? etc, and a number – all at least 8 characters long). I don’t care how much scanning and .htaccess files you take on, without changing your FTP password, you’re never going to fix the problem.

  5. That explain why I tried leaving a comment the other day and a weird website popped up when I pushed reply.

    Also, when I look at B&P from my phone and push the comments button… it takes me to a page to log into gmail. Weird huh

      • Not sure if this is what Deborah means, but there has been a problem with the Posts and Comments links (in the top right corner) on my iPhone since the major hack and overhaul last spring 2010 (it worked just fine before that) and I would imagine it could be a problem on other mobile devices, phones, iPods, iPads. Maybe you could see if you get the same thing on your iPad. In Safari I get a ‘.Mac Reader Error’ and ‘Server Not Responding…’ messages. I have no idea if it helps, but when I go to ‘Settings’ > ‘Safari’ > ‘Developer’ > turn ON ‘Debug Console’ then click on the links, I usually get descriptions of HTML errors but I’m not getting any on those links right now (I am getting a Javascript Error on line 173 message on the homepage though but it doesn’t seem to give me any unusual problems). After trying several browsers, I found that Opera works but even with that I had to figure a way to make it work from a bookmark. I tried Vanilla Surf, Atomic Lite, and Mercury browsers and they don’t do anything, just stay on the homepage. I hope you can get that working again sometime.

        Unrelated, I’m getting a ‘Stack overflow line: 16’ error when I click the Edit button on my desktop computer. But I can still edit just fine.

        • I’ll look into it, but as far as my “fixing it”, I wouldn’t be too hopeful. My knowledge is pretty much limited to activating and deactivating plugins. I know very little php and/or html.

Comments are closed.